Service Interuption

Incident Report for Medium

Resolved

This incident has been resolved.
Posted Jun 22, 2022 - 11:58 PDT

Investigating

Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Jun 22, 2022 - 11:57 PDT