Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted Oct 21, 2022 - 15:26 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Oct 21, 2022 - 15:25 PDT