Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted Oct 09, 2020 - 07:28 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Oct 09, 2020 - 07:20 PDT