Story Stats Disruption

Incident Report for Medium

Update

We have resolved the disruption to story stats.
Posted Jul 07, 2025 - 08:29 PDT

Investigating

We are currently seeing issues within the stats page. We are investigating the issue.
Posted Jul 07, 2025 - 07:41 PDT
This incident affects: Medium Front End.