Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 06, 2019 - 07:55 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 3 months ago. Jun 06, 2019 - 07:53 PDT