Issues with signing up to Medium
Incident Report for Medium
Resolved
This incident has been resolved.
Posted Aug 24, 2020 - 11:11 PDT
Investigating
We're currently investigating issues with the account creation process on @medium. We apologize for the inconvenience and thank you for your patience while we're working on a fix.
Posted Aug 24, 2020 - 09:08 PDT
This incident affected: Medium Front End.