Service Interuption

Incident Report for Medium

Resolved

This incident has been resolved.
Posted Apr 07, 2024 - 14:33 PDT

Investigating

Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Apr 07, 2024 - 14:31 PDT