Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted Sep 05, 2022 - 09:08 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Sep 05, 2022 - 09:07 PDT