Service Interuption

Incident Report for Medium

Resolved

This incident has been resolved.
Posted Mar 25, 2024 - 03:02 PDT

Investigating

Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Mar 25, 2024 - 03:01 PDT