Repeating images/titles on the profile page
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 13, 2019 - 05:18 PDT
Investigating
We are currently investigating an issue with repeating images and titles on the Medium profile page. We apologize for this, and have begun working on a fix. There is no action or editing required on your part.
Posted 3 months ago. Jul 12, 2019 - 18:30 PDT