Service Interuption

Incident Report for Medium

Resolved

This incident has been resolved.
Posted Apr 12, 2024 - 12:43 PDT

Investigating

Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Apr 12, 2024 - 12:42 PDT