Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 11 days ago. Nov 02, 2018 - 23:07 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 11 days ago. Nov 02, 2018 - 23:05 PDT