Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 9 months ago. Jan 19, 2017 - 10:00 PST
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 9 months ago. Jan 19, 2017 - 10:00 PST