Service Interuption

Incident Report for Medium

Resolved

This incident has been resolved.
Posted Dec 05, 2023 - 13:39 PST

Investigating

Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Dec 05, 2023 - 13:07 PST