Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted Aug 29, 2022 - 21:03 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Aug 29, 2022 - 21:02 PDT