Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted Aug 11, 2020 - 19:08 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Aug 11, 2020 - 19:07 PDT