Issues with accessing Medium
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 06, 2019 - 10:38 PDT
Investigating
We are currently investigating issues with accessing various pages across Medium. No data has been lost. We're working to fix the issue.
Posted 4 months ago. Jun 06, 2019 - 07:19 PDT