Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 9 days ago. May 14, 2019 - 08:22 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 9 days ago. May 14, 2019 - 08:22 PDT