Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted Mar 11, 2020 - 15:01 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Mar 11, 2020 - 15:00 PDT