Service Interuption

Incident Report for Medium

Resolved

This incident has been resolved.
Posted Aug 31, 2023 - 11:26 PDT

Investigating

Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Aug 31, 2023 - 11:25 PDT