Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 13 days ago. Sep 06, 2019 - 11:53 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 13 days ago. Sep 06, 2019 - 11:49 PDT