Service Interuption

Incident Report for Medium

Resolved

This incident has been resolved.
Posted Feb 27, 2023 - 21:49 PST

Investigating

Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Feb 27, 2023 - 21:36 PST