Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 14 days ago. Jul 09, 2019 - 10:24 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 14 days ago. Jul 09, 2019 - 10:23 PDT