Service Interuption

Incident Report for Medium

Resolved

This incident has been resolved.
Posted Nov 09, 2022 - 14:57 PST

Investigating

Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Nov 09, 2022 - 14:56 PST