Service Interuption

Incident Report for Medium

Resolved

This incident has been resolved.
Posted Apr 13, 2024 - 10:42 PDT

Investigating

Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Apr 13, 2024 - 10:41 PDT