Issues with post previews on profile pages
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 19, 2019 - 12:17 PDT
Investigating
We are currently investigating an issue with repeating or missing images and titles on Medium profile pages. There is no action or editing required on your part. Please bear with us.
Posted 3 months ago. Jul 19, 2019 - 00:05 PDT