Service Interuption

Incident Report for Medium

Resolved

This incident has been resolved.
Posted Apr 21, 2023 - 23:27 PDT

Investigating

Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Apr 21, 2023 - 23:26 PDT