Issue with tax form at https://medium.com/me/partner/taxes
Incident Report for Medium
Resolved
This issue has been resolved.
Posted Jul 28, 2020 - 16:32 PDT
Investigating
We are experiencing an issue with the iframe at medium.com/me/partner/taxes which is preventing the completion of filing tax forms. Please bear with us while we work to resolve this.
Posted Jul 28, 2020 - 13:20 PDT
This incident affected: Medium Front End.