Service Interuption

Incident Report for Medium

Resolved

This incident has been resolved.
Posted Apr 18, 2024 - 05:29 PDT

Investigating

Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Apr 18, 2024 - 05:28 PDT