Issues with accessing Medium
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 20 days ago. May 03, 2019 - 10:39 PDT
Investigating
We are currently investigating issues with accessing various pages across Medium. No data has been lost. We're working to fix the issue.
Posted 20 days ago. May 03, 2019 - 09:54 PDT