Service Interuption

Incident Report for Medium

Resolved

This incident has been resolved.
Posted Nov 30, 2023 - 17:16 PST

Investigating

Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Nov 30, 2023 - 17:11 PST