Service Interruption (Cloudflare)
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 02, 2019 - 07:59 PDT
Investigating
Some users are experiencing problems accessing Medium due to a Cloudflare issue, our team is aware and investigating.

Please see https://www.cloudflarestatus.com/incidents/tx4pgxs6zxdr for more information.
Posted 3 months ago. Jul 02, 2019 - 06:58 PDT