Membership Creation Issue
Incident Report for Medium
Resolved
This issue is now resolved. If you feel your billing was impacted, please email yourfriends@medium.com.
Posted Oct 17, 2019 - 12:31 PDT
Investigating
We are experiencing an issue with the @Medium membership payment page showing an error. Please refrain from repeatedly trying to subscribe, and if you have charge errors contact us at yourfriends@medium.com.
Posted Oct 17, 2019 - 12:19 PDT
This incident affected: Medium Front End.