Issues with accessing Medium pages
Incident Report for Medium
Resolved
This incident has been resolved. If you are still having issues, please contact us at help.medium.com.
Posted Apr 04, 2020 - 20:52 PDT
Investigating
We are currently experiencing an issue with accessing various Medium pages on certain browsers. As a current workaround, please try using Medium from another browser to see if that helps.

We apologize for the inconvenience and thank you for your patience as we're working on a fix.
Posted Apr 04, 2020 - 02:02 PDT