Service Interuption

Incident Report for Medium

Resolved

This incident has been resolved.
Posted May 11, 2022 - 06:23 PDT

Investigating

Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted May 11, 2022 - 06:21 PDT