Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted Dec 06, 2021 - 16:57 PST
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Dec 06, 2021 - 16:38 PST