Service Interuption

Incident Report for Medium

Resolved

This incident has been resolved.
Posted Jun 20, 2022 - 23:42 PDT

Investigating

Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Jun 20, 2022 - 23:40 PDT