Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted Jan 03, 2022 - 00:18 PST
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Jan 03, 2022 - 00:06 PST