Service Interuption

Incident Report for Medium

Resolved

This incident has been resolved.
Posted Jan 06, 2022 - 20:22 PST

Investigating

Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Jan 06, 2022 - 20:11 PST