Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted Aug 12, 2020 - 01:05 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Aug 12, 2020 - 01:03 PDT