Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 25, 2019 - 11:01 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 4 months ago. Jun 25, 2019 - 10:56 PDT