Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted Apr 08, 2022 - 11:44 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Apr 08, 2022 - 11:29 PDT