Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted Oct 04, 2022 - 09:39 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Oct 04, 2022 - 09:38 PDT