Service Interuption

Incident Report for Medium

Resolved

This incident has been resolved.
Posted Feb 06, 2023 - 21:06 PST

Investigating

Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Feb 06, 2023 - 21:04 PST