Service Interuption

Incident Report for Medium

Resolved

This incident has been resolved.
Posted Apr 08, 2025 - 04:11 PDT

Investigating

Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Apr 08, 2025 - 04:10 PDT