Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 20 days ago. Jan 29, 2019 - 10:31 PST
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 20 days ago. Jan 29, 2019 - 10:17 PST