Service Interuption

Incident Report for Medium

Resolved

This incident has been resolved.
Posted Feb 24, 2025 - 02:35 PST

Investigating

Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Feb 24, 2025 - 02:34 PST