Issues with accessing Medium
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 2 months ago. May 15, 2019 - 13:34 PDT
Investigating
We are currently investigating issues with accessing various pages across Medium. No data has been lost. We're working to fix the issue.
Posted 2 months ago. May 15, 2019 - 06:52 PDT