Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted Nov 30, 2020 - 07:54 PST
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Nov 30, 2020 - 07:42 PST