Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted Jul 27, 2020 - 07:30 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted Jul 27, 2020 - 03:32 PDT